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What you will fi nd in this guide…
This guide was designed to make the process of using Paraben’s P2 Commander easy. We have 
included the basic information for:

Registration of the product• 

Use of the dongle and associated dongle manager• 

Basics of Starting a case • 

Sorting through evidence • 

Basics of Reporting• 

There are many other aspects and features available in P2 Commander that are covered in the 
main electronic Help File. 
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Introducing P2 Commander
Paraben P2 Commander is a comprehensive forensics tool for examining disk drives, media, and 
disk images to fi nd, organize, and analyze several different fi le types including:

Documents• 
Text fi les• 
E-mail fi les• 
Network email fi les• 
Chat logs• 
Graphics fi les• 
Deleted fi les• 
Archive/compressed fi les• 
Windows registry• 
Databases fi les• 
Applications• 
XML fi les• 

P2 Commander lets you sort the fi les into categories, preview the fi les, view text and hex 
information for the fi les, and hash the fi les to ensure that they haven’t been changed or corrupted.  
You can use P2 Commander to analyze all data present on a computer hard drive regardless of 
whether the fi les have been previously deleted.
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P2 Commander Related Applications
Paraben manufactures two applications related to P2 Commander that let you create and read 
disk images: 

-Paraben Forensic Replicator    -Paraben P2 Explorer

Paraben Forensic Replicator
Paraben Forensic Replicator is a tool that lets you image disk drives, USB drives, and other 
storage media connected to a computer.  This tool creates verifi ed fl at fi le images of the media in 
question and is court accepted as a forensic imaging tool. Refer to the help fi les that come with 
Paraben Forensic Replicator to learn how to create and save disk images.

P2 Explorer
P2 Explorer is a free application that lets you mount disk images and access them as if they were 
a read-only drive on your computer.  It assigns a drive letter to each mounted virtual hard drive 
on your computer.  Once mounted, you can access fi les and applications as though they were 
installed on your computer.  

   Caution: Malware and other malicious software contained in an image can infect your 
computer if accessed using P2 Explorer.



6       © 2011 Paraben Corporation.

Installing and Confi guring P2 Commander
The installation process has three parts:

Installation• 
Registration• 
Installation of the FOCH database (optional)• 

After installing P2 Commander, you must register the program. Without a registration P2 
Commander can only be used for 30 days or 23 uses.  This section outlines the installation 
process.  

Computer System Requirements
The following computer system requirements are needed to use P2 Commander.

Operating system: Microsoft Windows 2000 or later 32 bit OS.• 
RAM: 1 GB, (1.5 GB recommended)• 
.Net Framework version 2.0 or later.• 
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Installing P2 Commander
P2 Commander Installation fi les have been provided for you on the same drive as your dongle. 

Go to the P2 Commander directory and select the setup fi les.

To install P2 Commander
On the welcome screen, click 1. Install Now
When the install wizard displays, click 2. Next.
Accept the license agreement, click 3. Next.
Do one of the following:4. 

Type the location on the folder where you want to install P2 Commander, click • Next.
Click • Browse and select the location of the folder where you want to install P2 
Commander, than click Next.
Click • Next to keep the default location.

Click 5. Install.
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Registration (IACIS 2010 Version)

Install P2 Commander from your IACIS Thumb Drive Dongle or from your registration site account 
at http://register.paraben-forensics.com

Your IACIS Thumb Drive is Your Dongle: 
Once you have installed Device Seizure, simply make sure your IACIS Thumb Drive Dongle is 
plugged into the machine whenever you are running Device Seizure. 

Updating P2 Commander:
IACIS users will receive free updates for one year (until April 2011). When a new version is released, 
a special version will be available for IACIS users. You can log into your registration site account 
using your Product ID (PID) found on your packaging and download the latest version. 

Upgrading P2 Commander:
The IACIS version of P2 Commander is identical to the regular version except for the type of Dongle. 
In order to continue receiving new versions of P2 Commander after the fi rst year, you will simply 
need to purchase an annual maintenance subscription (currently only $220).
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Installing the FOCH Database
The FOCH (Filter Out Common Hash) database is a set of hashed fi les that are associated with 
many common operating systems.  When installed; P2 Commander uses this set of hashed fi les 
to fi lter out these common fi les so that it doesn’t have to sort and rehash them each time you do a 
scan.

If you received P2 Commander on a CD, the FOCH database should have arrived in the package 
on a separate CD.  If not; the FOCH database can be downloaded from the Internet (instructions 
below).  When you start P2 Commander there is a link at the bottom of the information in the 
Welcome screen.  You can download it using this link.

To install the Foch Database
Do one of the following:1. 

Open P2 Commander.  In the welcome screen click:• 
 • Download the database from Paraben’s site.

Download the database directly from:• 
 • http://www.paraben-forensics.com/downloads/foch.exe

Start the Foch.exe application.2. 
Type the location where you want to place the database.  It should be in folder named 3. 
CommonFiles (NIST) placed in the root directory where you installed P2 Commander.  The 
correct location is provided by default if you selected the default location for installing P2 
Commander.
Click 4. Install.
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Working in P2 Commander
Once P2 Commander is registered with either a license key or with a dongle you are ready to start 
using the program.  

Exploring the P2 Commander interface
P2 Commander has four main information panes as shown in the following image.

The panes are:

Evidence pane – Upper left – Displays the fi le system and fi les found in the evidence items.• 
Files pane – Upper right – Displays fi les in a folder of groups of fi les that have been sorted.• 
Properties pane – Lower left – Displays fi le properties.• 
Information view pane – Lower right – Shows fi le data including images, thumbnails, text, and • 
HEX data.

NOTE: You can add, remove, or resize panes as you work to see more or less information.  If you 
want to reset the display to the default settings you can click View > Restore Layout in the main 
menu.
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P2 Commander Data Examination Process
P2 Commander has several important functions that you will need to be familiar with and perform 
in order to store and examine the evidence.  The functions include:

Create a case• 
Add evidence• 
Sort fi les• 
Examine fi les• 
Create reports• 
Export data• 

Each of these is outlined in this guide.  More comprehensive information is available within the 
Help fi les located in P2 Commander under the Help menu.
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Creating a Case
When you initially start P2 Commander you need to create a case.  If you attempt to add evidence 
before creating or opening a new case the New Case wizard will prompt you to name the case fi le 
so that it can store your case data.  This ensures that your case data is automatically saved and 
reduces the risk of information loss due to equipment failure. 

Creating a case consists of naming the fi le and providing details related to the case.  The New 
Case wizard provides you with fi elds that you can use to type your fi le information.

To create a new case

From the main menu click 1. File > New Case.  Or, in the tool bar; click the New Case icon. ( )

In the Welcome tab, click 2. Next.
In the Case Properties tab, do the following:3. 

Enter a name for your case in the Case Name fi eld.  The case name is required and serves • 
as the name of the fi le in which your case is stored.  Initially P2 Commander saves your 
case in the folder where P2 Commander is installed.  Case names should be descriptive to 
easily locate them later.
Enter a description of the case.  While not required, this data can be very useful if time has • 
passed and you are re-examining a case, or if someone else needs to look at the case.
Click • Next.
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4. In the Additional Information tab type the following information:  (This step is optional) 
Investigator name• 
Agency/Company• 
Phone number• 
Fax number• 
Email address• 
Comments• 

Each fi eld in this tab uses menus that remember information you have previously typed.

Click Finish.

NOTE: This information displays in reports that you create.
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Adding Evidence
After creating your case you need to add the evidence.  Adding evidence is the process of 
selecting which fi les and information that you want to search.  P2 Commander lets you specify any 
of several data storage types. These include:

Logical drive or folder•  – Reads the fi les and folders that are stored on the hard drive in 
hierarchical order.  You can select an entire disk, or a folder on the disk.
Physical drive•  – Reads all data on the disk regardless of whether it is stored in a logical folder 
on the disk drive or not.
Image fi le•  – Reads a stored hard drive image.  Has the ability to read images in most common 
formats.  Has an auto-detect capability as well.
E-mail database•  – You can select from one of many current email applications, or you can use 
the auto-detect function.
Chat database•  - You can select from one of many current online chat applications, or you can 
use the auto-detect function.
Registry fi les• 
Other • – Reads OLE storage and archive or compressed fi les.

One of the advantages of P2 Commander is the ability to have many different types of evidence 
in one case for analysis. For example if I am processing a case that is a hard drive, and a network 
e-mail storage (MS Exchange EDB) I can add them both to one case and
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search them all at once. You have up to 64 Terabytes (theoretical) of data that can be stored in a 
case.

Adding Evidence Dialog:
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Note: When using the auto-detect function you have the option to select a fi le or folder.  For most 
fi le and data sources you should select File.  Only select Folder if the object you want to search is 
the actual folder itself. For most auto-detect options you should select the fi le and P2 Commander 
will determine what type of fi le it is.

To add evidence
Create a case. See Creating a Case on page 15.

Click the Add Evidence icon 1.  or click File >Add Evidence.

In the Add New Evidence screen select the type of evidence that you want to add; then click 2. 
OK.

Browse to the fi le or folder you want to select; then click 3. OK.

Type the name for the evidence.  By default this is the name of the object you select when you 4. 
browse.  It is the name that displays in the list of evidence objects. Click OK.

Select from the options you want to use when adding the evidence; then click 5. OK.
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Search Deleted Files and Folders – looks for data that may have once resided in the folder • 
of object, but was deleted.

Add Trash folder to the NTFS root – If you are searching a disk drive this places the hidden • 
trash fi les directly under the root for the evidence item.

Recover folder structure for bad images – If the items being scanned have been corrupted • 
this feature attempts to restore the data to its original state

Add the unallocated space folder to the NTFS root – Adds a folder for data located in • 
unallocated space on the hard drive.  Unallocated space includes space that is not used by 
the fi le system and space outside of formatted areas.

NOTE: Some options in this step are not available with specifi c types of evidence.

After you add the evidence it displays in the case evidence pane of the application.  The pane 
can be expanded making it easier to view, sort, and examine the fi les.
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Sorting Files
After evidence is added you can sort the fi les into categories and related fi le types.  This lets you 
quickly search for suspicious graphics, text, email, or chat fi les.  P2 Commander automatically 
sorts fi les into the following types:

 
Documents• 
Email• 
Chat• 
Spreadsheets• 
Graphics• 
Databases• 
Executable• 
Compressed• 
Multimedia• 
Text• 
XML• 
Encrypted• 
Others• 
Image Analyzer Results• 
Unallocated Files• 
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The Image Analyzer results are populated with images that meet the specifi cations for probability 
of containing pornographic/illicit content.  These settings can be confi gured to be more or less 
precise.

The Unallocated Files Menu Items in the sort can be expanded to show all of the above 
categories.  These categories are populated with fi les and data found in unallocated disk space on 
the computer.

To sort fi les
In the tab menu at the bottom of the evidence pane, click 1. Case Explorer. 
In the Case Explorer list, right click an item.  You can select a top level item, or drill down into 2. 
the fi les and select a sub-folder.

In the drop-down menu, click 3. Sorting.

Check the boxes next to the sorting options you want to use; then click 4. Next.  The options are:
Save current wizard options as the default• 
Sort deleted data• 
Sort unallocated space• 
Sort fi le slack – (unused space between the end of the fi le data and the end of the disk • 
cluster that the fi le is stored in)
Calculate hash codes for partitions• 
Use Image Analyzer – Looks for pornographic content• 
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Sort recursively (Email Databases, OLE storages, Archives, Etc.) – Searches through these • 
data sources for attached or compressed fi les that can be opened and sorted.

5. If you enabled the Image Analyzer; confi gure the settings for analyzing images, then click 
Next.  Analyzer settings include:

Engine sensitivity – a higher setting fi nds more pornographic content, but also includes • 
more false positives.
Use fi le fi lter – Ignores fi les larger or smaller than the options you select.• 
Ignores fi les outside of the height and width sizes you specify.  Settings are specifi ed in • 
number of pixels.

6. If you enabled sorting of email databases and compressed fi les, select the types of data you 
want to fi nd in your search, click Finish.

NOTE: You can only sort one set of data at a time.  To sort a new set of data; right-click the 
sorted data object and in the menu click Clear Sorting.

7. To see the sorted fi les; in the tab menu of the evidence pane click Sorted Files.
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Examining Files
After sorting the fi les the next step is to examine and determine what you have acquired.  P2 
Commander gives you several options for examining fi les and data sources.  These include the 
following tools:

Text viewer• 
Hex viewer• 
File viewer• 
Email viewer• 
Chat viewer• 
Thumbnails viewer• 
File slack hex viewer• 
File slack text viewer• 

When you select a fi le or folder the appropriate options display in the tabs located in the 
information view pane.  For example; if you select a folder that has no graphics the thumbnails tab 
is unavailable.  The information displays in the pane when you click the tab. 
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To view fi les and fi le information
In the main menu click 1. View > Viewers and ensure that all viewer options are selected.

In the Evidence pane expand the folders until you reach the folder or fi les you want to look at.  2. 
If you want to examine a specifi c fi le click it in the Files pane.

In the Tab Menu at the bottom of the pane click the appropriate tab to see the information 3. 
displayed in the format you want.  For example; click HEX to view the HEX for the fi le.

Click the edge of the pane to resize it if necessary.4. 

NOTE: File properties including size, creation date, and similar fi le properties display in the File 
Properties pane in the lower left of your screen
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Creating Reports
P2 Commander lets you export four different standard reports.  The reports types include:

HTML investigative report•  – This creates a graphical report in HTML format.  The report lets 
you add all evidence and include thumbnails of fi les and links to fi les in the report.  The report 
lets you select the types of evidence you want to display and has many options for adding or 
leaving out evidence.
Simple text report•  – This report exports to a .txt fi le.  It provides options for including or leaving 
out specifi c information, but all evidence is listed in text format.
CSV text report•  – Exports information into a spreadsheet.  This has options similar to the text 
report.
HTML evidence summary report•  – Gives a brief overview of the evidence for managers and 
supervisors.

When creating reports you can select specifi c fi les and information that you want to add to the 
report.  You can select this information by checking the boxes to the left of the fi les in the Files 
pane.  You can also export all evidence.
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To create reports 
If you want to create a report that shows specifi c data; navigate to the data in the Case 1. 
Explorer tab of the Evidence pane and then in the Files pane check the box next to the fi les or 
folders you want to include.

Click the Report icon (2. ) or from the main menu, click File > Generate Report.
In the initial screen of the report wizard select the type of report and the location where you 3. 
want to save the report.  By default the report and all associated fi les are saved in a new folder 
using the fi le name of the case.

Click through the remaining screens in the wizard and select the options you want to display 4. 
in your reports.  These include: File Types, File Properties, Case Information, create a report 
with all evidence or only selected fi les, etc.  The report options change depending on the type 
of report you select.  For complete information on all report options see the help fi les in P2 
Commander.

Click 5. Finish to begin the process of creating the report.  The creation process might take 
several minutes depending on the size and options you select when creating the report.
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Exporting Files
P2 Commander lets you export fi les and folders found in the evidence to your computer or a 
location you specify.  P2 Commander exports the fi les along with a hash fi le that can be used to 
ensure the data isn’t changed.  You can use the check boxes in the Files pane to select which fi les 
and folders you want to export.

To export fi les and folders:

In the Files pane, check the boxes next to the fi les and folders you want to export.1. 

Click the Export icon (2. ), or in the Main Menu; click Tools > Export.
Browse to the location where you want to place the evidence; then click 3. OK.
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Additional Features
This quick start guide has the basic features you need to begin working in P2 Commander.  
However; P2 commander has a powerful set of additional features that you can use to make your 
analysis easier and more complete.  These features are listed in the section below with a brief 
description.  Complete documentation for each is available in the P2 Commander Help fi les.

Search – look for text strings in the evidence.• 
Sorted Files Search – search for fi les by type, size, creation date, on hash data.• 
Mount Image tools – mount disk images to your computer and use them as if they were a part • 
of your operating system.
Hashing tools – create and manage your fi le hash data.  It also lets you create hash-based • 
exclusion databases for fi les common to computers on your network.
Bookmarks – Creates links to quickly fi nd locations and fi les in the evidence.• 
Case History – Displays a list of tasks and processes performed that relate to the case.  Lists • 
times with the events.
Options wizard – change and save the default settings for P2 Commander.• 
Graphical options – determine which panes display when you open P2 Commander.  Also, • 
resize and close panes when necessary.
Files pane tabs. – navigate between multiple windows in P2 Commander and view the • 
information contained in each.
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There are many additional resources available through the primary help fi le for P2 Commander located 
under the Help menu in the tool. Paraben also offers a variety of resources to help including:

Paraben Forum• 

Paraben Training• 

Paraben Tech Support Ticket System• 

For more information on any of these or Paraben’s other forensic technology please visit us at:

www.paraben.com or email us at forensics@paraben.com


